Aller au contenu
Namspopof

Bugs et oublis sur la version 0.99.7

Messages recommandés

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 
Signalez ici les bugs et oublis que vous rencontrez sur le Mod SI !

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 
Avant de signaler un bug, assurez vous d'avoir bien installé la dernière version du Mod SI
 
Pour installer correctement le Mod SI, toutes les informations concernant l'installation se trouvent dans le premier message de ce topic. Vous trouverez aussi dans ce topic le résumé des bugs qui ont déjà été signalés, ainsi que les bugs qui seront corrigés pour la prochaine version.

Modifié par HK 47

Partager ce message


Lien à poster
Partager sur d’autres sites

- Je viens de constater un bug très gênant.

 

J'envoie Leia voler une technologie impériale. Elle disparait puis revient au bout d'un certain temps. Et bien désormais, à chaque fois que je souhaite l'envoyer quelque part, et donc que doit se créer l'icône "voler technologie", le jeu plante. J'ai le même retour au bureau si je souhaite envoyer quelque part un autre héros capable de voler des technologies comme Winter.

 

Dans mon cas, il s'agissait de la campagne Bataille pour le Noyau en Tech 4. J'avais volé la technologie du DSI Mk. I et lancé sa production dans un centre de recherches.

 

---------------------------------------------------------------------

 

- Sur Rendili, les hardpoints des stations Golan sont tous à 91% en début de bataille. Je n'ai pas ce problème lorsque je suis en position de défenseur de la planète. J'ai remarqué le même problème en attaquant La Roue qui était aussi à 91%.
 
Je viens surtout de remarquer le même problème en jouant à la campagne Guerre Civile I (Rebelles), toutes les unités Impériales de la bataille en orbite de Yavin étaient aussi à 91%. Même chose avec les unités Rebelles de la bataille de Géonosis et de Mon Calamari (campagne officielle d'EAW avec l'Empire).
 
J'en conclue donc que ce bug affecte toutes les unités et bâtiments de l'IA qui ont été déposées sur une carte spatiale. C'est-à-dire uniquement celles qui n'ont pas été construite/achetée par l'IA. C'est vraiment bizarre.
 
eaw_2060.jpg

Modifié par DKS_MaXoO

Partager ce message


Lien à poster
Partager sur d’autres sites

- Les points critiques des CR-90 sur Commenor (sol) sont à 91% et celles-ci attaquent l'infanterie (pas pu tester avec des véhicules) lorsque l'on prend le contrôle d'une d'entre elles avec des pilotes (merci d'avoir implémenté ça au passage c'est sacrément kiffant :D).

- Les points critiques des DSI dans la mission de Turkana sont à 91%, même problème pour la base astéroïde pirate ouest de Malastare.

Modifié par HK 47

Partager ce message


Lien à poster
Partager sur d’autres sites

Si tu suis les instructions du fichier "Optimisation du jeu" installé avec le mod tu ne devrais quasiment plus avoir de soucis.

 

 

Cela a l'air de fonctionner merci.

J'ai commencé le scénario qui proposait le plus de planetes a savoir d'égal à égal et je me suis aperçu que le Consortium, la CSI, la CorSec, les Hutts, les pirates et toutes les factions mineures qui apportaient une variété géniale lors des conquetes avaient elles aussi disparues :(

Si vous ne comptez pas réintégrer le grand conflit galactique pourriez vous a défaut inclure tout ce qui faisait sa saveur chez son petit frère ? J'en demande peut etre beaucoup je ne sais pas mais c'est quand meme une deception je ne le cache pas :pleure:

Modifié par djazore

Partager ce message


Lien à poster
Partager sur d’autres sites

- Certains hardpoints du cuirassé stellaire Vengeance sont difficiles à détruire.

 

hardpo10.jpg

 

- La barre de vie du cuirassé stellaire Vengeance est parfois difficilement visible car elle est très haute.

- Le Bulwark Mk. III devrait produire des soldats de la Nouvelle République en Tech 4 et 5, pas des soldats Rebelles.

- Dans Guerre Civile Galactique IV en jouant avec les Rebelles, je vois que l'Empire a deux fois Dorja.

eaw_2022.jpg

- Je constate un problème avec un des modèles d'arbre. Lorsqu'il se balance au vent, il s'étire étrangement. Il semble que cela ne se produit que lorsqu'il se trouve sur un relief.

eaw_2024.jpg

Modifié par HK 47

Partager ce message


Lien à poster
Partager sur d’autres sites

Conflit sectoriel coté empire en difficulté maximum après avoir éradiqué la corruption sur Metellos, les forces terrestres et spatiales se replient toutes seules vers la planète la plus proche (coruscant en l’occurrence). Ça me l'a fait deux fois et jamais sur les autres planètes. En revanche sur certaines planètes, même après éradication de la corruption, les traits restent entre plusieurs planètes sur la vue galactique

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour alors voilà : Dans la mission d'Ilum dans la campagne officielle de EAW côté Empire on ne peut pas construire de droïde sonde donc bloqué ici

Construis une usine de droïdes.

Dans la mission de Kessel dans la campagne officielle de EAW côté Rebelle les navettes sont toutes neutralisées et la flotte de l'empire est détruite mais la mission ne se termine pas ! Le Délivrande ne peut pas récupérer les prisonniers à l'intérieur :/

ça a été testé et ça marche.

Partager ce message


Lien à poster
Partager sur d’autres sites

En conquête galactique, celle avec les pirates qui sont partout. Je joue Empire, lorsque les Yuzhan Vongs m'attaquent avec 2 vaisseaux mondes (je crois, ceux qui sont immenses et qui ressemblent à des champignions), les deux vaisseaux sont l'un dans l'autre au spawn de la map spatiale et sont indestructibles.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour à tous.

 

Il me semble que le bug que je vais vous soumettre et connu mais je ne retrouve pas la rubrique. Quelque soit la campagne mon jeu ralenti à mort ou plante (tout est en pause sauf la souris) au bout du 10e mois.

Y a -t-il une solution svp? c'est entrain de me dégouter de jouer et pourtant ce jeu est mon préféré !!!

 

Merci encore à tous pour votre travail.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir, meilleurs voeux pour 2016 !

 

Je tiens avant tout à féliciter l'équipe du mod pour tout ce travail accompli, j'ai du mal à décrocher de mon ordi depuis que j'ai découvert son existence !

 

Cependant, j'aimerais signaler quelques "bugs", enfin plutôt des erreurs liées aux campagnes "L'aube de la rébellion" et "Guerre Civile I" :

 

- Dans "La naissance de la rébellion", il faut conduire Kota et la frégate Délivrance sur Kamino à partir de Dantooine. Cependant, le seul chemin possible passe par Yaga Minor (ou, en rusant un peu, par Coruscant) où une énorme flotte Impériale attend...c'est fait exprès ? J'ai triché en modifiant le XML pour faire apparaître la frégate et Kota à Bothawui puisque c'est le seul chemin possible pour aller à Kamino.

- Plus tard, Dantooine est évacué, la flotte est parti sur Yavin IV mais les troupes terrestres sont restées en orbite. Là encore, impossible de les faire quitter le secteur sans passer par Yaga Minor.

Je n'ai pas pu continuer plus loin, j'ai eu un plantage lors d'une bataille spatiale et mes dernières sauvegardes ont été corrompues (mais je sais pas si ça a un rapport avec le mod).

 

- Dans Guerre Civile I, j'ai trouvé les missions impliquant l'escadron Rogue et Luke très difficile (Dantooine et Ralltir). Elles sont pas impossibles non plus mais restes très frustrantes. En fait je les trouve mal équilibrées, il faudrait pouvoir emmener des troupes capables de s'infiltrer jusqu'à ces deux mondes (comme des lance-missiles ou des véhicules par exemple). Or, en plus, on ne peut entraîner des troupes à cause de la limite de population.

- Plus tard il faut emmener Luke, Han et Leia sur Kabal, ce qui est impossible car la planète est isolée et n'est reliée à rien. Du coup on ne peut finir la campagne. J'en suis là aujourd'hui.

 

Voilà, ce n'est pas vraiment des bugs mais des blocages et des points d'améliorations.

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci, j'ai essayé et j'ai encore eu un plantage, ça doit pas venir que de là.

 

Je sais que quand j'ai joué à la campagne de l'add-on sans le mod, j'ai pas eu de crash.

De même quand j'ai joué à la campagne originale côté empire AVEC l'add-on (mais avec la version 0.99.3 et sans le correctif), j'ai pas eu de crash.

Là j'essaie la même côté Rebelle, pour voir si ça vient du correctif.

 

Autre chose : ça rame à mort sur la carte terrestre de Sluis Van, sans doute la cascade qui fait chuter les FPS.

 

EDIT :

Pour l'instant aucun plantage sur la campagne officielle moddée côté Rebelle.

Ah et la commande "trigger" dans la console n'est pas reconnue, contrairement à ce qu'il y a marqué dans un des XML.

 

EDIT2 : Ah si ! Ca a planté ! Je me disais aussi...

Au fait, Kashyyyk reste inaccessible lorsqu'il faut envoyer une troupe terrestre. Je crois que ça a déjà été signalé.

Modifié par Aghora

Partager ce message


Lien à poster
Partager sur d’autres sites

En utilisant l'étoile de la mort en défense, si vous voulez cliquer sur les icones d'amélioration sur une base spatiale, au lieu d'activer l'amélioration, vous activez le feu de l'étoile de la mort... C'est ce qu'on appelle une bavure si elle est en orbite de Coruscant...

 

La CSI produit des malveillants en 19 secondes, c'est chaud quand elle les lance direct au début d'un scénario ou vous n'avez pas grand chose pour défendre.

 

Le scénario bataille pour le Braxant coté Empire est un peu chaud... J'ai perdu en 4 minutes, l'IA possède un peu trop d'unités dès le départ.

Partager ce message


Lien à poster
Partager sur d’autres sites

- Les soldats de la Marine Impériale sont dans le menu des bâtiments spatiaux. Ils devraient être dans le menu de l'infanterie ou des héros spatiaux.
- Les commandants de la Marine Impériale sont dans le menu des bâtiments spatiaux. Ils devraient être dans le menu des héros spatiaux.
- Les remorqueurs CT-11 sont dans le menu des bâtiments spatiaux. Ils devraient être dans le menu des chasseurs.
C'est voulu, c'est pour faire de la place dans les héros et mettre toutes les unités de la marine dans le menu spatial.


- La frégate MedStar a la mention "Contient : Frégate MedStar" dans ses hardpoints.
C'est comme le vaisseau de Tyber Zann, je ne crois pas pouvoir l'enlever.


- Les droïdes B2 écartent les bras lors des déplacements.
Il faut supprimer les fichiers des précédentes versions.


- Geonosian_CSI_Team est en doublon dans CSI_Containers et CSI_unit_Infantry.
CSI_Containers n'est plus dans le gameobjectfiles : fichier supprimé pour la prochaine version complète.


TEXT_UNIT_MERCENAIRE_MID_RIM_SQUAD
Mercenaires de la Bordure Médiane
Groupe de mercenaires de la Bordure Médiane

 

TEXT_UNIT_MERCENAIRE_OUTER_RIM_SQUAD
Mercenaires de la Bordure Extérieure
Groupe de mercenaires de la Bordure Extérieure

 

TEXT_UNIT_MERCENAIRE_HUTT_SPACE_SQUAD
Mercenaires de l'Espace Hutt
Groupe de mercenaires de l'Espace Hutt

Trop long pour vendre l'unité.


- En déployant un UDM avec le Consortium, je n'ai aucun choix de construction possible.
Je viens de le tester, je n'ai eu aucun souci.


- Quand on capture un esquif cargo avec un infiltrateur des SpecForces, on se retrouve avec un esquif cargo piloté par Chewbacca. :tongue:

eaw_2100.jpg
ça je ne pourrais pas le corriger, je suis obligé de mettre le même modèle pour le véhicule capturé, quelque soit l'unité qui capture. Modifié par HK 47

Partager ce message


Lien à poster
Partager sur d’autres sites

- Dans la campagne "Une occasion rêvée", lorsque je me sers de Tyber Zann et d'Urai Fen pour acheter des technologies, les deux héros ne réapparaissent pas.

eaw_2101.jpg

Modifié par DKS_MaXoO

Partager ce message


Lien à poster
Partager sur d’autres sites

- Les droïdes B2 écartent les bras lors des déplacements.

Il faut supprimer tous les fichiers commençant par CIS_SBD... (ou CSI_SBD... je sais plus) dans le dossier MODELS avant d'installer la dernière version.

Ces fichiers et beaucoup d'autres seront bien sûr supprimés quand je compilerai une version complète du mod.

 

petit HS : je reprends le jeu et le mod, est-ce qu'il est possible de jouer en mode fenétré ?

Je ne sais pas

 

- Dans la campagne "Une occasion rêvée", lorsque je me sers de Tyber Zann et d'Urai Fen pour acheter des technologies, les deux héros ne réapparaissent pas.

Après plusieurs tests, je suis effectivement tombé sur ce bug. Mais bizarrement il n'est pas systématique, plutôt une fois sur deux. Je n'ai pas réussi à trouver ce que je faisais d'identique lorsque ce bug produit. Si tu trouves je dis bravo.

 

Je viens de faire une vérification.

J'ai pris la campagne conquête galactique = sans aucune modif

Et là aucun problème = les troupes sont bien positionnées sous leurs icônes respectives.

Le problème pourrait-il venir de :

<Campaign_Set> Sandbox_Grand Conflit_147 </Campaign_Set>

ou

<Empire_Story_Name>Story_plots_sandbox_EPGC_empire.xml</Empire_Story_Name>

Je n'y comprends rien ?

Je rectifie

J'ai pris les lignes ci-dessus de la conquête galactique = 77

Et là impec tout est bien placé

je pense très fortement que c'est bien dans ces lignes que ce trouve le problème.

Si tu fais des modifs,c'est normal de faire apparaitre des bugs. Je vais pas reprendre toutes tes modifs mais je peux te dire que les menus dépendent de la ligne

<Empire_Story_Name>Story_plots_sandbox_EPGC_empire.xml</Empire_Story_Name>

Modifié par HK 47

Partager ce message


Lien à poster
Partager sur d’autres sites

- Il semble que les frégates médicales ne peuvent pas être produites sur Bilbringi.

C'est comme ça pour tous les planètes sans surface, c'est comme les chasseurs terrestres/spatiaux.

 

- Les héros automatiques suivants ont toujours leur logo coloré en jaune dans la carte galactiques lorsqu'ils ont été tués. Il faudrait faire disparaître leur logo à leur mort

C'est normal pour la plupart. Il faut exclure tous les héros sensés disparaitre puis réapparaitre (vol de technologies, neutraliser des héros, contrebande...)

- Le Dominant, le Ralroost, le Mon Mothma, le Maria, le Défiance, la plupart des Jedi constructibles du Nouvel Ordre Jedi, et probablement quelques autres héros encore n'ont pas leur logo en haut à droite lorsqu'ils sont construits. Tous les héros devraient être représentés en haut à droite de la carte galactique puisqu'ils peuvent mourir et que leur logo disparait ensuite.

C'est voulu. Tous les héros apparaissent en haut à droite en mode tactique mais en mode galactique, j'ai réservé cet espace aux héros non constructibles. Modifié par HK 47

Partager ce message


Lien à poster
Partager sur d’autres sites

- Sur Giju, il y a dans le décor une frégate DP20 invisible.

 

eaw_2090.jpg

 

- Le centre des Douanes Impériales apparait sur le radar comme une station XQ1.

 

eaw_2089.jpg

 

- Sur Kiffu, il y a deux postes de milice (désertique et Kiffar). Le poste de milice des Kiffar est dans tous les menus.

 

- La carte terrestre de Mandalore fait beaucoup lagger. Cela doit être à cause des cascades d'eau et de la pluie.
 
Petites corrections :
 
TEXT_UNIT_REBEL_JUGGERNAUT

Char d'attaque rebelle

Char d'attaque Rebelle

-> Il faut supprimer aussi le retour à la ligne qui est en trop et pose un petit problème.

 

TEXT_TOOLTIP_REBEL_JUGGERNAUT

Le char d'attaque rebelle est un transport sur roues directement inspiré des véhicules d'assaut lourds Juggernaut utilisés par l'Empire. Il se différencie de ses analogues impériaux par des formes plus arrondies et un armement différent composé de canons laser et de canons blasters montés sur des tourelles. Le char d'attaque rebelle n'a pas été conçu pour être un monstre des champs de bataille mais pour servir avant tout de transport de troupes.

Le char d'attaque Rebelle est un transport sur roues directement inspiré des véhicules d'assaut lourds Juggernaut utilisés par l'Empire. Il se différencie de ses analogues Impériaux par des formes plus arrondies et un armement différent composé de canons laser et de canons blasters montés sur des tourelles. Le char d'attaque Rebelle n'a pas été conçu pour être un monstre des champs de bataille mais pour servir avant tout de transport de troupes.

 

----------------------------------------------------------------
 
Parmi ce qui semble provoquer de gros ralentissement sur la carte galactique, j'ai l'impression qu'il y a  :
- le déplacement des unités invisibles (clairement cela ralenti le jeu jusqu'à la fin de leur déplacement). Je me demande si ce n'est pas simplement le modèle d'origine (halo jaune) qui bug et qui serait à changer.
- les messages de l'holocron qui nous dit en 2-3 messages qu'une faction a remporté/perdu une planète (à moins que le vrai ralentissement ne vienne de la capture d'une planète qui génère de nouveaux calculs et déplacements de flottes de l'IA). Parfois je mets en pause un certain moment pour que tous les messages défilent et s'arrêtent, et cela va beaucoup mieux. Il faudrait voir si limiter les messages à ce qui concerne uniquement le joueur aide.
 

----------------------------------------------------------------

Dans plusieurs campagnes, j'ai régulièrement de nombreux crashs, m'obligeant à sauvegarder très régulièrement et à revenir souvent en arrière. Dans la campagne Films et séries, cela me fait disparaître ma sauvegarde automatique. Dans la campagne Bataille pour le Noyau, elle est heureusement conservée.

 

Dans Bataille pour le Noyau, j'ai très facilement un crash lorsque j'essaye d'utiliser un contrebandier et que de nombreux réticules "voler de crédits" se créent. J'ai aussi un crash si j'essaye de les déplacer en groupe (juste les prendre avec la main, le crash intervient avant de pouvoir choisir une planète).

 

Je constate aussi que le très grand nombre d'unités d'infanterie dans les compagnies "classiques" provoque facilement des crashs du jeu si on en déploie plusieurs ou qu'on en a plusieurs en garnison.

 

----------------------------------------------------------------
 
- Dans la campagne Films et séries, au bout de la moitié de la campagne, je peux déployer mes troupes dans les combats spatiaux et terrestres mais je ne peux plus les sélectionner pour les utiliser. Je dois donc arrêter là cette campagne.
eaw_2029.jpg
 
J'ai chargé une sauvegarde un peu moins récente pour pouvoir continuer la campagne. Elle se passe bien mais le bug revient, cette fois au cours même d'une bataille spatiale ! Au début tout se passe normalement, et puis ensuite mes nouvelles unités spawnées ne sont plus sélectionnables. De plus, les nouveaux vaisseaux ennemis qui sont déployés n'affichent plus de hardpoints. Après la fin de la bataille, le bug est revenu partout est plus aucune bataille n'est jouable comme dit plus haut.
 
Un des premiers vaisseaux ennemis (on voit les hardpoints) :
eaw_2069.jpg
Un des vaisseaux déployés par la suite (on ne voit pas les hardpoints) :
eaw_2070.jpg
 
----------------------------------------------------------------
 
Pas vraiment un bug mais je le signale quand même. Je viens de remarquer que lorsqu'on charge une sauvegarde faîte au cours d'une bataille terrestre, l'IA réagit à l'assaut totalement différemment. Au lieu d'envoyer progressivement ses troupes, elle envoie absolument toutes ses troupes d'un coup !
 
eaw_2033.jpg

Modifié par DKS_MaXoO

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour à tous,

 

En introduction : a chaque nouvelle version du mod, je désinstalle tout (avec Revo) et réinstalle histoire d'éviter des clash avec les ancienne version.
                           Par ailleurs, j'utilise la version Gold (mais j'installe EaW et FoC de manière distincte).

 

J'ai repéré quelques bugs/problèmes :

 

* Bug : Campagne Guerre Civile 2 Empire : crash/retour bureau dès la fin de la bataille d'Hoth terrestre (systématique)

 

* Bug : La CSI peut construire des Subjugator en 1 minute! Pourtant l'XML associé indique 600 secondes si je ne m'abuse

 

* Problème : La CSI dispose de trop de bombardiers à mon avis. En cas de grosse bataille spatiale on est submergés par des dizaines d'escadrons et forcement on se fait démolir. C'est notamment visible dans la campagne Pacification coté impérial quand on passe en techno 1 et du coup les destroyers impérieux ne lâchent que 3 escadrons de chasseur. Je réalise que c'est voulu car la CSI avait un grand nombre de chasseurs mais la ça devient injouable....

 

Merci a votre travail (que je suis depuis la version 0.8) !

Partager ce message


Lien à poster
Partager sur d’autres sites

@Tomcat : Merci pour la réponse. Je ne savais pas pour le modificateur de temps, ce qui expliquer plein de choses et pas que pour le Subjugator :)

 

En ce qui concerne le crash après Hoth, je suis le seul à l'avoir eu?

Partager ce message


Lien à poster
Partager sur d’autres sites

- Les Kiffars disparaissent à leur mort.

C'est le cas de toutes les unités qui n'ont pas d'animation de mort.

- J'ai l'impression que les Demeures de Sorcières de Dathomir ne génèrent pas de nouvelles unités après la mort des premières Sorcières.

Il y a 2 minutes à attendre.

- Le rechargement du bouclier du Voyageur Galactique - Amiral Ackbar a une durée limitée. Pareil pour le Défiance - Amiral Ackbar, et le Maria - Capitaine Verrack.

J'ai laissé l'aptitude de base aux héros.

- Rhinnal indique "Importantes ressources minières" mais il n'est pas possible d'y construire de complexe minier. Il faudrait retirer la mention.

C'est pour la mine astéroïde.

Partager ce message


Lien à poster
Partager sur d’autres sites

- Dans Bataille pour le Noyau, mes bâtiments terrestres disparaissent régulièrement. Il semble que ce soit à cause du cuirassé stellaire Souverain.

 

eaw_2097.jpg eaw_2098.jpg

Modifié par DKS_MaXoO

Partager ce message


Lien à poster
Partager sur d’autres sites

Je ne sais pas si cela est voulu mais quand je prend une planète avec l'empire ou la rébellion je me retrouve avec un bâtiment ou une station station spatial

C'est depuis la 0.99.6. L’envahisseur dispose ainsi des installation planétaires. C'est pour toutes les planètes habitées.

Partager ce message


Lien à poster
Partager sur d’autres sites

- L'animation de la destruction d'une colonie spatiale Golan II est trop rapide

 

- De meme pour le lucrehulk de combat

Je ne crois pas pouvoir le changer.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×