Aller au contenu
Bert

Problèmes Sauvegardes

Messages recommandés

J'ai trouvé ma réponse ... désolé ^^

 

"Voici quelques astuces découvertes par les membres du forum Star Wars : Empire at War sur le Réseau Gamers et Stratégie pour optimiser les performances du jeu et pouvoir sauvegarder de plus grosses parties.


Pour cela il faut :

- Ouvrir le dossier des sauvegardes (C:\Users\votrenom\AppData\Roaming\Petroglyph\Empire At War - Forces of Corruption\Save par défaut sur Windows 7) et mettre en lecture seule le fichier SLOT0.
Cela supprime la sauvegarde automatique et permet un gain de chargement énorme.
- Commencer une partie et enregistrer.
- Faire Alt-Tab pendant le jeu et trouver le fichier SLOT correspondant à la save dans le dossier des sauvegardes.
- Transformer le fichier en le compressant via les options avancés de Windows dans les propriétés.
- Retourner dans le jeu puis jouer et sauvegarder sur le même fichier.

La sauvegarde automatique étant annulée, pensez à sauvegarder manuellement assez souvent.

 

Avec ces différentes méthodes additionnés, cela permet de gagner en souplesse."
 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour

 

Tout d'abord un grand merci aux moddeurs qui font un travail de génie depuis tant d'années :D

 

Et puis ensuite la tragique histoire de mes sauvegardes qui ne marchent pas :'(

 

Quand je fais une sauvegarde de mes parties je ne peux pas la relancer sinon le jeu crash. j'ai tout bien installé etc... mais j'ai peut-être oublier quelque chose...

 

Edit : je viens de voir la "technique" pour compresser etc... mais mes sauvegardes restent inutilisables :s

Modifié par xGReeGZx

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai déjà vérifié ça ne vient pas de là mais c'est bizarre car mes sauvegardes ne dépassent pas 4Mo et j'ai eu beau tout essayé ça ne fonctionne pas.  :mur:

Partager ce message


Lien à poster
Partager sur d’autres sites

Essaye en réinstallant le mod sinon je ne vois pas d'ou sa pourrait venir

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai essayé mais j'ai l'impression que cela m'a créé plus de problèmes qu'autre chose. Désormais, à chaque fois qu'il y a une bataille quelque part, j'ai un freeze de plusieurs dizaines de secondes. :/ J'ai le sentiment que le jeu freeze parce qu'il essaye de faire une sauvegarde automatique dès qu'une planète est conquise quelque part et qu'il n'y arrive pas.

 

eaw_2027.jpg

 

J'ai supprimé les fichiers du dossier sauvegarde mais le problème n'a pas disparu. Je vais réinstaller le mod pour voir si le problème persiste. C'est vraiment bizarre parce que je n'avais pas cela avant.

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

plantage du jeu / Retour Windows :

 

Sur la campagne "Routes Commerciales" coté Rebelle.

Je remporte une bataille terrestre sur Javin et donc je capture la planète.

Lors du retour sur la carte galactique, mon jeu est pris de méchant lag rendant la partie quasi injouable (avant la bataille j'avais quelques petits lag de temps à autres mais rien de méchant, la routine en somme)

J'ai le réflexe de sauvegarder "au cas ou". Mon jeu a planté en pleine sauvegarde (qui existait déjà, je ne faisais que l'écraser) ce qui a entraîné la perte de cette dernière.

 

Je publie ce bug, au cas ou je ne serais pas le seul (vue la gravité des conséquences ... ).

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello all I'm running Windows 10 shoulds work with this goal 8 / 8.1 as well. This problem is Indeed a permission error with the OS, in order to work around this issue run the game, hit the windows key to minimize it and open task manager. Right click on the EAW process and go to properties / compatibility tab and check the box to "run as administrator" Thanks to the person Who Mentioned This worked on the steam release (steam running as admin.) As That led to my fix for the normal retail (gold) version. I'm using mod launcher to start the game and  I run that as admin. just to be safe - and it also Seems To fix the random crashing error. I hope this helps someone who enjoys this great game and the awesome mods That people-have created for it. Enjoy!

Modifié par draegoth

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai finalement décidé de tout réinstaller car le problème ne partait pas et c'était la bonne décision. Je n'ai plus ces longs freezes à chaque fois qu'une planète est conquise quelque part. Donc personnellement, je déconseille fortement de suivre les indications qui sont dans "Optimisation du jeu".

 

- Ouvrir le dossier des sauvegardes (C:\Users\votrenom\AppData\Roaming\Petroglyph\Empire At War - Forces of Corruption\Save par défaut sur Windows 7) et mettre en lecture seule le fichier SLOT0.
Cela supprime la sauvegarde automatique et permet un gain de chargement énorme.
- Commencer une partie et enregistrer.
- Faire Alt-Tab pendant le jeu et trouver le fichier SLOT correspondant à la save dans le dossier des sauvegardes.
- Transformer le fichier en le compressant via les options avancés de Windows dans les propriétés.
- Retourner dans le jeu puis jouer et sauvegarder sur le même fichier.

La sauvegarde automatique étant annulée, pensez à sauvegarder manuellement assez souvent.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Finalement, j'ai toujours ces longs freezes... :-(

 

En chronométrant, j'ai un freeze qui dure 1 minute 20 à chaque fois qu'il y a une bataille ennemie quelque part. Cela rend le jeu totalement injouable. Suis-je le seul avec ce problème ?

Modifié par DKS_MaXoO

Partager ce message


Lien à poster
Partager sur d’autres sites

salut , tu devrais reinstaller une ancienne version , cela permettra de voir si le probleme vient de la nouvelle version ou de ton materiel/configuration .

Partager ce message


Lien à poster
Partager sur d’autres sites

Finalement, j'ai toujours ces longs freezes... :-(

 

En chronométrant, j'ai un freeze qui dure 1 minute 20 à chaque fois qu'il y a une bataille ennemie quelque part. Cela rend le jeu totalement injouable. Suis-je le seul avec ce problème ?

 

Slt. Il y a un message quelque part de HK47 qui dit que les laggs et freezes viennent d'un problème de l'IA qui est en correction. Certains scénarios buggent moins que d'autre. Personnellement je joue conflit galactique 147 planètes j'ai quelque freeze mais pas énormément en revanche le jeu lagg pas mal. Mais ça reste jouable.

 

 

A part ça je viens de perdre ma sauvegarde ainsi que la sauvegarde automatique. Elles n'apparaissent plus dans le menu chargement. Je suis vert je devais être vers 19 mois de jeu sur conflit 147 planètes. J'avais conquis tout le noyau le braxant et une bonne partie de la bordure médiane.

Il n'y a rien dans ma corbeille certains ont une solution pour la retrouver?

 

Edit: Elles sont présentes dans le dossier save sous forme de slot0 et slot 1 mais elles font 0 octets. Est ce qu'à partir d'une certaine taille les sauvegardes s'arretent si on les a pas compressé ?

Modifié par jilome

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut !

Je ne sais pas s'il y a moyen de récupérer tes sauvegardes, mais si elles ont disparu c'est qu'il y a une raison, Est-ce que le jeu a planté à un moment donné ou à un autre ?  Il m'arrive fréquemment d'avoir des retour sous le bureau et si cela produit lors d'une sauvegarde on la perd.

 

Je me permet de te donner 2 conseils :

 

1. compresse toujours tes sauvegardes, même si depuis quelques versions le problème de la limite de taille a été résolu

2. Pour chaque scénario que tu fais, créé au minimum 2 sauvegardes (pour 147 planètes je te recommande même 3 ou 4) ensuite sauve régulièrement tes parties. Comme ça si une de tes sauvegardes plante ou venait à disparaître, tu ne serais pas obligé de tout recommencer

Modifié par Spock72.ch

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut !

Je ne sais pas s'il y a moyen de récupérer tes sauvegardes, mais si elles ont disparu c'est qu'il y a une raison, Est-ce que le jeu a planté à un moment donné ou à un autre ?  Il m'arrive fréquemment d'avoir des retour sous le bureau et si cela produit lors d'une sauvegarde on la perd.

 

 

Non aucun bug j'ai quitté le jeu normalement après avoir pris deux nouvelles planètes et après avoir sauvegardé. Je pense que la sauvegarde devait simplement être trop grosse.

Je vais faire comme tu as dit.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je crois avoir dénicher un bug :

 

J'ai l'impression que la compression des sauvegarde entraîne des plantages aléatoires du jeu.

 

J'ai joué joué jusqu'a présent sur le scénario "la nouvelle guerre mandaloirienne" côté rebelles sans compresser les fichier des sauvegardes et je n'ai pas eu de soucis. Je compresse les fichiers et hop ni une ni deux ça plante retour sur le bureau avec le message "Windows a rencontré un problème et a dû fermer le programme"

 

Je vais à nouveau tester sans la compression et on verra bien.

 

Toutefois je viens de me rappeler en écrivant ces lignes que le slot de la sauvegarde automique est compressé et que jusqu'a présent il n'y a pas eu de plantage. Alors Hazzard (or not Hazzard  ? Duke ne saurait le dire) :)

 

A vous de voir

Partager ce message


Lien à poster
Partager sur d’autres sites

Finalement, j'ai toujours ces longs freezes... :-(

 

En chronométrant, j'ai un freeze qui dure 1 minute 20 à chaque fois qu'il y a une bataille ennemie quelque part. Cela rend le jeu totalement injouable. Suis-je le seul avec ce problème ?

 

J'ai aussi ces freezes. C'est assez difficile de donner quelque chose de précis, mais pour ma part j'ai l'impression qu'il y a des salves de freezes, avec un maximum de 10 secondes de freeze toutes les 20 secondes de jeu pendant 5 minutes (correspondant peut-être aux prises de planète.. ?).

Est-ce qu'on pourrait désactiver le droïde histoire de soulager les scripts... ? (je désactive déjà ses astuces par précaution, mais j'ai aussi quelques ralentissements le temps qu'il fasse apparaître ses messages..).

 

A côté de ça je me suis tenté la carte d'égal à égal de base à 50 planètes, et le jeu était d'une fluidité que je ne lui avais pas connu depuis très longtemps. Moins de salves de freeze aussi. Mais au bout de 2h j'ai tenté une sauvegarde, et j'avais déjà dépassé la limite... J'ai retenté une autre sauvegarde qui a planté le jeu.

 

Deux choses: soit l'idée de compresser les sauvegardes était effectivement foireuse (je tenterais aussi sans), soit il y a depuis l'an dernier des ajouts du mod qui déstabilisent le jeu.

Partager ce message


Lien à poster
Partager sur d’autres sites

Le problème de freeze est en cours de correction. Je seras d'ailleurs interéssé si certaines personnes acceptaient mes fichiers corrigés pour les tester pendant leurs parties.

Modifié par HK 47

Partager ce message


Lien à poster
Partager sur d’autres sites

J'accepte !

 

Si tu as un lien pour télécharger un éventuel patch... ?

Modifié par Alegs

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens de réfléchir à un truc qui pourrait paraître idiot: mais si on focalisait le mod SI sur la période fin de guerre des clones / pré-Yavin / Yavin-Hoth / Hoth-Endor / Endor, et qu'on mettait tout le post-Endor dans un mini-mod, ça soulagerait pas le système et ça permettrait pas d'avoir moins de problèmes de sauvegarde... ?

 

Mais si j'ai bien compris le problème, c'est plutôt le développement viral de l'IA qui semble poser soucis.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

Je up ce topic sans grand espoir ^^ mais ma sauvegarde a planté. Je devais être sur le mode l'empire en guerre avec seulement 37 planètes. Mais j'ai du sauvegarder lors d'un gros combat spacial. Je n'aurai pas du je crois. Je précise que j'avais supprimé l'auto-save et compressé la save.

Si vous avez du nouveau pour m'aider sur ce problème n'hésitez pas. Bonne nuit.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

J'ai trouvé une solution sur W7 pour restaurer les sauvegardes corrompues. J'ai cru ne plus pouvoir reprendre ma partie. Mais si vous avez écrasé régulièrement la même sauvegarde W7 peut retrouver celle effectuée juste avant que ça crash.

Je vous expliquerai mieux ce soir.

Sauf si vous connaissiez déjà l'astuce ^^

Bonne journée a tous.

Partager ce message


Lien à poster
Partager sur d’autres sites

Non moi je connais pas, j'aimerais bien savoir ce que tu as fait.

 

Il paraît aussi qu'en lançant le jeu en compatibilité Windows XP (ou ME je ne sais plus), comme ça déplace le lieu d'enregistrement, y a moins de chances que ça plante. Enfin si j'ai bien compris.

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui, c'est possible. J'ai vu ça aussi. Je détaillerais ce que j'ai fais dans la soirée :) je ne sais pas si ça marche avec XP par contre...

Partager ce message


Lien à poster
Partager sur d’autres sites

Non moi je connais pas, j'aimerais bien savoir ce que tu as fait.

 

Il paraît aussi qu'en lançant le jeu en compatibilité Windows XP (ou ME je ne sais plus), comme ça déplace le lieu d'enregistrement, y a moins de chances que ça plante. Enfin si j'ai bien compris.

 

Comme prévu un petit tuto expliquant comment j'ai "restauré" ma sauvegarde, bonne soirée :)

 

1) Aller dans le dossier de sauvegarde du jeu

2) choisir le bon slot, vous pouvez vous repérer avec l'heure de la sauvegarde.

3) clic droit sur le slot - propriétés-versions précédentes.

4) L'ordinateur va chercher si une version précédente existe

5) Si une version précédente est trouvée, vous aurez alors la possibilité de

cliquer sur "Restaurer".

6) L'ordinateur va donc remplacer la dernière sauvegarde corrompue par l'avant dernière

non corrompue.

Petites précisions :

Dans mon cas j'ai réalisé cette manoeuvre sur une sauvegarde compressée comme expliqué dans

le tuto. Et j'ai sauvegardé régulièrement sur le même slot.

Je n'éxécute aucun mode de compatibilité pour lancer FOC.

J'ai testé cette manip qu'une seule fois puisque je n'ai pas eu d'autres problèmes du même

type.

J'espère que ça pourra vous aider, et que ça fonctionnera pour vous.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai pas réussi à le faire fonctionner ton truc. Je crois que ça nécessite de créer des points de restauration système.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×