Aller au contenu
sete-rome

Problème d'installation du Mod SI

Messages recommandés

Suis bien les instructions d'installation et vérifie que tu installes le mod dans le bon dossier comme indiqué dans l'installateur. le mod apparaitra dans le pétrolauncher s'il est bien installé.

Partager ce message


Lien à poster
Partager sur d’autres sites
23 hours ago, HK 47 said:

Suis bien les instructions d'installation et vérifie que tu installes le mod dans le bon dossier comme indiqué dans l'installateur. le mod apparaitra dans le pétrolauncher s'il est bien installé.

Bonjour,

Autant pour moi:blush:... Je n'avais jamais utilisé le "pétrolauncher", que j'ai trouvé...

ça fonctionne.:D

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut tout monde ! Comment allez-vous ?

 

J'ai fait un bond important en passant de la 0.99.7 à la 1.2d au début tout se passait bien, puis suite à quelque freeze désagréables, je me décide à refaire une installation propre en virant  tout et en réinstallant Foc (version CD). j'ai ensuite respecté à lettre l'installation des patch et du mod.

 

Jusque là pas de problème, mais ou le bas blesse c'est que Foc m'a obligé à installer une version antérieur de DirectX (la 0.9C de 2006) Quand j'ai voulu réinstaller la bonne version (celle de juin 2010 pour 8.1) au début tout ce passe bien, mais à la fin de l'installation j'ai un message d'erreur "une erreur interne s'est produite. Consulter les dossier DXError.log et DirectX.log situés dans le dossier Windows pour résoudre le problème". De base j'ai DX11 d'installé pour 8.1 et les jeux récents.

De guerre lasse et après quelques recherches j'ai opté pour la désinstallation manuelle de DirectX en vue d'une réinstallation et là le problème persiste et signe (Grrrr !)

 

autre souci quand ke cherche à lancer le jeu via le petrolauncher j'obtiens un message d'erreur "l'opération demande une élévation" dois-je comprendre qu'il faut updater le launcher ? Si oui où trouve-t-on la Màj ? Lors de ma première installation, j'avais dû biaiser en utilisant la technique d'Assassin (Mods/Swsi puis lancer avec Swsi.bat)

 

Voilà je crois que je me suis planté en beauté. J'espère que vous serez en mesure de m'aider car maintenant que j'ai regoûter à SI, j'en veux encore plus !

 

Je vous remercies déjà pour votre future aide

 

Ma config :

I7 4760 (3.60 GhZ)

16 Go de RAM

W8.1 (64 bit)

GTX 770 (4Go)

Partager ce message


Lien à poster
Partager sur d’autres sites

Commence par réinstaller TOUTES les versions de directX, de la plus ancienne à la récente : 9.0b, 9.29 puis 11.

https://www.clubic.com/telecharger-fiche10906-directx.html

 

Le launcher ne se met pas à jour, c'est le jeu qui te demande une élévation, ce qui est logique si directX n'est plus installé correctement.

 

Pour info, chaque version de directX est indépendante. L'installation de la 9.0 par le jeu ne pouvait donc pas te causer de problème, au contraire, elle était nécessaire.

Modifié par HK 47

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Après plusieurs mois, j'ai décidé de me mettre à jour du mod et d'y rejouer. Or, le jeu ne se lance pas.

Désolé si je suis long, mais j'explique :

 

Je désinstalle entièrement l'ancienne version du mod et le jeu (steam) et je réinstalle le tout dans les règles de l'art.

Je me rends compte que le jeu ne veut pas se lancer : quelque soit avec StarWarsG.exe, swfoc.exe, PetroLauncher.exe, PlayStrategicImprovement.bat (j'ai remarqué que vous aviez ajouté ces deux derniers fichiers).

Dans les deux premiers cas, j'ai un message d'erreur en anglais qui devait être "Unable to locate the installation path of Star Wars: Empire At War. Cannot launch the Forces of Corruption Expansion!" ; dans les deux autres cas, aucune réponse. Je me souviens d'ailleurs que j'avais déjà rencontré ce problème avant, mais impossible de me souvenir comment j'avais fait pour le résoudre, et de trouver une solution pertinente sur internet.

 

Je désinstalle et réinstalle tout proprement. Je suis scrupuleusement toutes les consignes d'installation et les conseils d'optimisation. Et là, changements :

Avec Steam, ce sont les versions de base du jeu qui se lancent, avec StarWarsG ou swfoc (je ne sais pas quelle est la différence, mais StarWarsG est plus gros), cette fois-ci, aucune réponse, avec le PetroLauncher, j'ai un message d'erreur en allemand (?), et avec PlayStrategicImprovement... ça marche !

 

MAIS, le lendemain, à nouveau impossible de lancer le mod. l'invit de commande disparaît sans l'avoir lancé. Je réfléchis : le seul changement intervenu est qu'il y a eu une sauvegarde auto parce que j'ai juste testé une petite partie (alors que j'ai bien fait la manip pour supprimer les sauvegardes auto...), je supprime donc ce fichier de sauvegarde.

Ça fonctionne, le mod se lance avec PlayStrategicImprovement !

Par contre, je subis les crashs lors des batailles (je vois que je ne suis pas le seul), mais, à chaque fois, je réussis à relancer.

 

Aujourd'hui, à nouveau, impossible de le lancer. l'invit de commande ne produit aucune réaction (tout est exécuté en tant qu'administrateur je précise). Même si j'élimine tous les fichiers de sauvegarde, rien ne se passe. Manifestement, ça n'avait donc aucun rapport, et je ne sais donc toujours pas pourquoi parfois j'ai réussi à lancer le mod, et d'autres fois impossible.

 

Certes, j'aurais peut-être besoin d'un meilleur PC, mais ce n'est pas non plus une antiquité, et le mod s'est bien lancé plusieurs fois et avant dans les anciennes versions...

 

Au final, j'ai presque renoncé définitivement à pouvoir jouer (au passage, félicitations aux moddeurs), mais ce qui m'énerve le plus, c'est de ne pas comprendre pourquoi ça ne fonctionne pas ! Comme si le mod refusait arbitrairement de se lancer.

Partager ce message


Lien à poster
Partager sur d’autres sites

PS : je me permets aussi un commentaire sur les crashs lors des batailles, qu'elles soient terrestres ou spatiales, et qui ont lieu (en ce qui me concerne) soit vers la fin, soit au moment de revenir à la carte galactique.

Hier -quand je réussissais à jouer- j'ai élaboré une tactique :

Détruire toutes les structures et la quasi-totalité des forces ennemies, se replier, puis revenir.

Là, soit il ne reste plus qu'une unité ennemie et on peut faire une résolution auto, soit les dernières unités ennemies qu'on avait laissé sur le champs de bataille étaient des garnisons de bâtiment, et alors il n'y a plus d'unité, on n'a qu'à revenir pour prendre le contrôle.

 

J'espère vous avoir été utile.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 21 heures, HK 47 a dit :

La question que je me pose en lisant tout ça c'est est-ce que tu arrives à installer et à jouer au jeu de base ?

 

Oui, ça, ça ne pose aucun problème.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour

 

Cela fait longtemps que je ne suis pas passé ici, et que je n'ai pas joué à Empire at wars et du coups, j'ai pensé de nouveaux à ce mods et à cette superbe refonte et j'ai eu la motivation d'y rejouer.

 

Le soucis est qu'il est dur de jouer sans avoir de crash, principalement combat spatiale mais certainement aussi combat terrestre. Sur Fondor en spatiale, je crash limite tout le temps sans raisons en pleines games avec un "Star wars empire at wars à cesser de fonctionner". Cela fait aussi ça sur d'autre map spatiale et donc le jeu devient un véritable calver. Le problème ne vient pas des fps.

 

Une solution?

 

Ma config: HP omen laptop Windows 10

                 GTX 1050

                I5 7700 2.50 HZ et 3.50 en mode turbo.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Je suis sur Steam, version id: 2820232 / 1.121.663024

 

Edit: Même sur la bataille terreste de fondor, quand je gagne, je crash.

 

Au final, je laisse tomber... Soit j'ai du loupé l'installation du mods, bien que j'en doute, soit il y a eux des améliorations, mais en mal. Ou puis-je me procurer les anciennes version du mods? Merci

Modifié par Darcan

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Tu as surement loupé quelque chose. Par exemple, vérifie que tu as bien supprimé les fichiers des précédentes versions. La version actuelle est particulièrement stable par rapport aux précédentes.

Modifié par HK 47

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai changé d'ordinateur, donc je n'ai aucune version precedente. J'ai installer le logiciel qui m'a mods le jeu, puis j'ai pris la version 1.2 que j'ai directement installé dans le répertoire du jeu, puis j'ai patch avec le 4g le launcher swfoc. Je me suis mis en comptabilité xp service pack 3 et admin

Modifié par Darcan

Partager ce message


Lien à poster
Partager sur d’autres sites

moi aussi je suis victime de crashs en escarmouche spatiale principalement, malgré l'installation du patch 4gb ; néanmoins j'ai désactivé la compatibilité xp service 3 parce qu'elle me faisait apparaître un message d'erreur parfois en lançant le jeu ou en aggrandissant l'écran : "could not reset the 3d device".
Ainsi donc je me demande quelle est la raison principale des crash...

Modifié par Commander[FR]

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 09/08/2018 à 13:54, Darcan a dit :

Bonjour

 

Cela fait longtemps que je ne suis pas passé ici, et que je n'ai pas joué à Empire at wars et du coups, j'ai pensé de nouveaux à ce mods et à cette superbe refonte et j'ai eu la motivation d'y rejouer.

 

Le soucis est qu'il est dur de jouer sans avoir de crash, principalement combat spatiale mais certainement aussi combat terrestre. Sur Fondor en spatiale, je crash limite tout le temps sans raisons en pleines games avec un "Star wars empire at wars à cesser de fonctionner". Cela fait aussi ça sur d'autre map spatiale et donc le jeu devient un véritable calver. Le problème ne vient pas des fps.

 

Une solution?

 

Ma config: HP omen laptop Windows 10

                 GTX 1050

                I5 7700 2.50 HZ et 3.50 en mode turbo.

 

j'ai absolument le meme problème

Partager ce message


Lien à poster
Partager sur d’autres sites

je viens de faire un test et il s'avère donc que le message d'erreur "could not reset the 3d device" s'affiche lorsque je joue en fenetré et avec mode de compatibilité (sans ce dernier il n'apparait pas) ; suite à cela j'ai donc mis le mode plein écran et il ne s'affiche plus.

Partager ce message


Lien à poster
Partager sur d’autres sites

steam + win 10

 

ne pas installer steam ou laisser steam installer les jeux dans programmes files .

 

steam et l'executable du jeu doivent etre lances en mode administrateur .

 

le patch 4gb doit etre applique sur l'executable du jeu pas le lanceur ou le raccourci steam .

 

empire at war ne supporte pas le alt/tab  (changement de fenetre ecran) pas de mode fenetre  , de meme desactive l'overlay de steam pour ce jeu  .

 

de pas utilise de mode de compatibilite , installez direct x 9.0c  .

 

pour les cartes nvidia , verifier les reglages alimentation pour performance et synchro vertical en adaptatif .

 

chez moi le jeu ne crash que sur certaines bataille terrestres , problemes lies a certaines cartes terrestres et peut etre qq unites pirates/hutt .

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

 

Il y a 2 heures, orvarth a dit :

steam + win 10

 

ne pas installer steam ou laisser steam installer les jeux dans programmes files .

 

steam et l'executable du jeu doivent etre lances en mode administrateur .

 

le patch 4gb doit etre applique sur l'executable du jeu pas le lanceur ou le raccourci steam .

 

empire at war ne supporte pas le alt/tab  (changement de fenetre ecran) pas de mode fenetre  , de meme desactive l'overlay de steam pour ce jeu  .

 

de pas utilise de mode de compatibilite , installez direct x 9.0c  .

 

pour les cartes nvidia , verifier les reglages alimentation pour performance et synchro vertical en adaptatif .

 

chez moi le jeu ne crash que sur certaines bataille terrestres , problemes lies a certaines cartes terrestres et peut etre qq unites pirates/hutt .

 

 

Pourquoi pas de mode de compatibilité ?

Modifié par Commander[FR]

Partager ce message


Lien à poster
Partager sur d’autres sites

les versions steam et gog sont deja modifies pour tourne sur win 7 et + , le mod compatibilite de windows est loin d'etre parfait .

 

il ne manque que qq fichiers direct x pour les executables 32bits , c'est le cas pour la plupart des jeux de cette epoque , si vous le faite tourne en mos win xp ou win 7 cela ne va pas ameliore les choses , au contraires des versions plus anciennes (dvd) qui necessite plus de modifs pour tourne sur les windows recents .

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×