Jump to content

Myth_Titans

Membre
  • Content Count

    133
  • Joined

  • Last visited

Everything posted by Myth_Titans

  1. ouais c vrai c pas un prob de déclencheur actif, ce qui est bizarre c'est que hier j'ai fait un déclencheur sur une carte vide ça ne marchais pas, aujourd'hui j'ai refais exactement la même chose et ça marche...
  2. j'en suis pas sur mais d'après ce que j'ai pu voir jusqu'a présent, un seul déclencheur pourrait être lancé à la base : je veux dire par là être activé sans autre déclencheur. donc si on a déjà un déclencheur actif et lancer immédiatement, et qu'on veut en activer un autre il faudrait apparemment utiliser un fire event, mais bon j'en suis pas du tout sur j'ai pas encore eu le temps d'essayer, juste une hypothèse...
  3. ben les maps existantes se trouvent dans C:\Program Files\Microsoft Games\Age of Mythology\rm (là ou tu dois mettre ta carte a toi)
  4. pour les exemples je te parle des maps qui sont déjà dans le jeu (anatolia, lac fantome, etc) ok pour la map que je suis entrain de faire je te montrerai quand je serais assez avancé
  5. crée un déclencheur, actif, lancer immdédiatement, condition : always, effet : set tech status, tu met le paramètre active et tu essaye de trouver dans la liste la technologie que tu veu (par exemple age 4 osiris (pour les tours je connais pas le nom)
  6. pour les exemples j'en ai pas pour l'instant car j'ai surtout intégré des déclencheurs dans des maps existantes, pas créé des maps, mais là je suis justement entrain d'en faire une, sinon tu peux toujours regarder les cartes déjà existantes. mais si t'a des questions tu peux les poser, j'essayerais quand même de te répondre. pour le xml tu dois mettre tout exactement comme je te l'ai mis (le ?, les "", les <>...)
  7. oups excusez moi j'ai dit une grosse connerie , dans options des dossiers, faut pas cliquer sur afficher les fichiers et dossiers cachés, faut aller décocher masquer les extensions dont le type de fichier est connu... j'ai été trop vite encore une fois lol
  8. ton alim est assez puissante ? (300W minimum) est ce que tu as bien branché l'alimentation directement sur la carte graphique ?(car moi avec la 6600 j'avais oublié de brancher ça, résultat écran noir ossi lol) t'a pas oublier de rebrancher le cable de l'écran ? (ça arrive)
  9. si tu parle de warcraft I ou II, cherche pas plus loin car ces jeux sont en 2D il me semble, si tu parle du III là t'a peut être une chance de touver qq chose pour exporter les models vers 3ds
  10. ouais c'est vrai que je suis plus vrmnt actif sur le forum mais j'viens y faire un tour de temps en temps pour voir se qui s'y passe lol pour ta carte aléatoire, déjà je te conseil d'afficher les extentions des fichiers pour pas avoir de mauvaise surprise avec les noms des fichiers xs et xml (panneau de configuration, option des dossiers, affichage, afficher les fichiers et dossier cachés). le fichier de ta carte aléatoire doit être en .xs. par exemple newmap.xs, et tu dois le placer dans C:\Program Files\Microsoft Games\Age of Mythology\rm. ensuite tu dois créer un fichier xml portant le même nom que ta carte, newmap.xml que tu place au même endroit. dans ce fichier écris ceci : <?xml version = "1.0" encoding = "UTF-8"?> <mapinfo details = "Ici tu met les infos sur ta carte" imagepath = "Ici tu met l'image que le jeu affichera pour ta carte" displayNameID="Ici tu met le nom de ta carte" cannotReplace=""/> Pour imagepath, tu dois écrire quelque chose comme ça ==> imagepath = "ui\ui map vinlandsaga 256x256". là ça utilisera l'image de vinlandsaga, si tu veux en utiliser une autre, il faut qu'elle fasse 256x256, que tu la convertisse en ddt (avec aomed), et que tu la place dans C:\Program Files\Microsoft Games\Age of Mythology\textures\ui ( à créer si il n'existe pas). Dernière chose pour ajouter ta carte à l'interface du jeu, il faut que tu ajoute ta carte à randommaps.set, il suffit de l'ouvrir (avec un éditeur de texte), et tu écris en dessous des autres : <map>NewMap</map> voilà c'est tout
  11. non y a pas d'autre moyen, enfin pas pour les cartes aléatoires en tout cas
  12. pour le cheval de troie je crois que tu as un objet ou il est directement construit, pour unit in area, il faut pas définir l'endroit ou l'unité doit aller, c'est une condition qui fait que quand l'unité sera dans la zone définie, il se passera l'effet que tu lui a affecté. si tu veu déplacer une unité utilise l'effet move to unit ou move to point
  13. pas besoin d'un logiciel spécifique, juste apprendre a "programmer" avec le script que les rms utilisent (sur le cd n°1 d'aom, dans "docs" il y a un tuto la dessus)
  14. j'ai l'impression qu'ils ont fait des optimisations graphiques, pck avant quand je tournais en very hight c'était jouable mais ça ramait qd même, mtn ça rame pratiquement plus et puis l'arrière plan du menu principal les graphismes ont changé aussi
  15. ouais sans doute, mais j'comprend pas les constructeurs d'avoir coupé un 1.7 ghz avec une x700...
  16. une X700 avec un proc a 1.7Ghz?... ça doit limiter pas mal les capacités de la carte graphique ça que se soit pour n'importe quel jeu (enfin je pense...), sinon comme l'a dis [AF]Ser3nity c clr que tu pourra jouer mais pas en maximum. ptit conseil, les effets (shaders...), tu peux les mettre en hight ou medium ça devrais pas vraiment poser de problème, par contre nivo textures met les en low et j'te conseil d'être en 1024x768
  17. heu oui il faut le créer (jai oublié de préciser lol)
  18. non (j'ai une geforce 6600 256mb), c'est parce que le le nombre de frames des ombres par secondes est trop faible, mais si je le met plus haut ça fais pas réaliste ça va bcp trop vite, donc j'ai réduit ça à 600 pour que se soit tellement peu fréquent qu'on ne le remarque pas. sinon ben j'ai réussi a intégrer le jour et la nuit dans les rms, on commence avec l'éclairage de base et pendant 10 minutes il va très lentement se changer pour devenir la nuit à la fin des 10 minutes, une fois celà fait il repars dans l'autre sens et pendant 10 minutes l'éclairage va changer pour a la fin redevenir jour complet, et ainsi de suite... vous pouvez télécharger les fichiers ici. plaçez le fichier fullmoon.lgt.xmb (ou fullmoon.lgt) dans C:\Program Files\Microsoft Games\Age of Empires 3 Trial\art\lightsets, plaçez les fichiers new england.xs et texas.xs dans C:\Program Files\Microsoft Games\Age of Empires 3 Trial\RM (faites une copie des fichiers originaux si vous voulez y revenir plus tard) voilà voilà...
  19. oulalalaaa on voit que j'étais faigué parce que je viens de m'apercevoir que j'avais dis des conneries lol. j'avais pas remarqué que le déclencheur était en fait placé comme commentaire, donc fatalement que ça marchais pas... donc en gros rmSetLightingSet("new england"); ça sert à définir l'éclairage de base et si on veut le modifier cet éclairage on doit utiliser les lignes de code de déclencheur. donc ça marche mais j'ai quand même un petit problème, la luminosité ne se règle plus par couleur comme dans aom, mais par inclinaison du soleil, ce qui veut dire que les ombres bougent pendant le déplacement du soleil. en gros si j'utilise les lignes de commande déclencheur qu'ils ont mis en commentaire, le passage entre les 2 luminosités vont se faire en 120 secondes (("Fade Time", 120)). ça fais très réaliste c'est vrai, mais avec un temps de fondu de 120 on voit les ombres qui saccadent pendant leur déplacement, donc je vais essayer de trouver un temps qui ferai plus ou moins réaliste et sans voir les saccades, dès que j'ai réussi je met en téléchargement les fichiers modifiés comme ça si vous n'avez rien compris c'est pa bien grave ^^ lol
  20. bon ben voilà un peu plus d'1 heure que je me suis lancé dans la gestion des éclairages et j'ai découvert pas mal de trucs. d'abord les nouveaux éclairages sont a placés dans C:\Program Files\Microsoft Games\Age of Empires 3 Trial\art\lightsets comme dit dans un autre topic. les quelques lignes de code qui créaient le déclencheur set lighting ne servent en fait à rien du tout, a mon avis c'était simplement des lignes test (d'ailleurs si vous regardez dans texas, elles n'y sont pas) // Sets up the lighting change trigger - happy dawn in New England // REMOVED /* rmCreateTrigger("Day"); rmSwitchToTrigger(rmTriggerID("Day")); rmSetTriggerActive(true); rmAddTriggerCondition("Timer"); rmSetTriggerConditionParamInt("Param1", 2); rmAddTriggerEffect("Set Lighting"); rmSetTriggerEffectParam("SetName", "new england"); rmSetTriggerEffectParamInt("FadeTime", 120); */ c'est la ligne rmSetLightingSet("new england"); qui définis l'éclairage de la carte, et il n'est apparemment plus possible de modifier l'éclairage par déclencheur (dans les rm du moins). donc si par exemple vous voulez utiliser le nouvel éclairage fullmoon.lgt.xmb, vous remplaçez la ligne rmSetLightingSet("new england"); par rmSetLightingSet("fullmoon"); bon ben voilà, moi je vais continuer à essayer de trouver le moyen d'établir une condition à partir du temps pour changer l'éclairage au moment voulu (j'ai essayer if (trTime() == 10) mais ça n'a pas marché )
  21. heu pour jour/nuit dans aoe3 ben je suis entrain de créer des nouvelles lumières et puis je vous dirais quoi pour le tuto sur les rm, celui de aom ne servira que très peu puisque dans aoe3 l'eau n'est plus définie de la même facon, pareil pour les falaises, les tribus natives doivent etres construites et définies, etc... ce qui fait que je le recommencerai pour aoe3^^ au fait je tiens a dire que si ils ne revoient pas un peu leur code de génération de rm, les cartes seront bcp moins aléatoires que dans aom ce qui est dommage je trouve... non on ne peut pas avoir l'éditeur dans la démo
  22. moi j'ai une unité native (je sais plus laquelle), ben elle se crée mais el n'apparait pa du tout
  23. j'avais fait ça pour aom, tu me donne envie d'adapter le code pour aoe3 j'vais essayer j'espère que les lights sont intégrées dans la démo
  24. salut, j'ai testé la démo je trouve le jeu super mais j'ia une petite question, j'ai bien coché dans les options les reflets dans l'eau mais j'ai ocun reflets, au lieu de ça j'ai, pour le menu principal par exemple, une couleur bleue claire totalement unie, on peut pas dire que ça fasse très joli, alors c'est pour savoir est ce que c'est un bug de la démo ou c'est ma carte graphique qui ne prend pa en compte les reflets dans aoe 3 ? (j'ai une radeon x300)
×
×
  • Create New...