Jump to content
wazup

Foire aux Questions

Recommended Posts

Bonjour à tous,

 

J'ai besoin d'une petite précision, car pas très clair moi, concernant l'installation de la 1.2n(dernière version). Il y'a un fichier data en plus du dossier mods remplaçant la 1.0, doit-on le laisser dans le dossier principal ou le coller dans le data du mod, merci de votre réponse.

 

Autre chose, j'ai les 2 versions steam et gog, avec les bugs que l'on connait et que j'ai pu voir que certains(voir tlm) avaient les mêmes. A savoir les probs de sauvegardes corrompues à la longue sur gog et la version normal, et sur steam les bugs de crash de fin de bataille(j'ai eu les 2). Je précise que j'ai bien lu toutes les recommendations et les éventuelles optimisations, et que j'ai pu les appliquer, inutile donc de me préciser ce qui a déjà été dit(je dis ça cordialement pour éviter des posts inutiles^^).

 

Donc ma question est la suivante, comment outrepasser ce bug sur steam de fin de bataille, y'a t-il des astuces à connaitre? Où doit-on tout simplement sauvegarder en pleine bataille ou fin de bataille et rechargez à chaque fois?

 

Je précise que j'ai pu tester et voir que la version steam a des améliorations de perfs(peut être lié à moins de pertes mémoires) et pas de bugs de sauvegardes(pas vu de ma part), tandis que la version gog ne crash pas en fin de bataille(le choix est difficile^^). Après je n'ai pas été très loin dans la version steam, qqu pourrait confirmer si il a eu des probs de sauvegardes corrompues par le temps de la game ou l'écrasement de saves sur cette version ou si les probs de saves n'existent plus sur celle ci.

 

Voilà c'est tout^^, sinon je prends bcp de plaisir sur ce mod et j'espère qu'il pourra aboutir d'une façon ou d'une autre à une version totalement stable.

 

Cordialement

 

 

Share this post


Link to post
Share on other sites

Salut,
Pour l'installation, il faut faire ce qui est indiqué : copier les dossiers "mods" et "data" dans le répertoire principal du jeu. Le dossier data est à part, il ne faut surtout pas le copier dans le dossier mods.

Pour ces bugs, je ne sais pas trop quoi te conseiller. Tu peux suivre les conseils du fichier optimisation du mod mais au final tout dépendra de ta façon de jouer. Pour moi que n'ai plus trop le temps de faire des partie longue, la version gog me convient très bien...

Share this post


Link to post
Share on other sites

Bonsoir tout le monde !

 

Je me suis remit à la modification d'XML et j'ai rencontré un phénomène des plus curieux, dans C:\Program Files (x86)\LucasArts\Star Wars Empire at War Forces of Corruption\Mods\Mod_Strategic_Improvement\Data\XML, je modifies divers fichiers concernant le consortium avec succès, mais dès que m'attaque au fichier underworld_units_infantery le jeu plante direct ! il se lance normalemement pendant quelques seconde et paf ! Retour sur le bureau !

 

J'ai recommencé mes modifs une dizaine de fois en réduisant différents paramètres et en faisant extrêmement attention à ce que je faisais afin d'éviter toutes manipulations hasardeuses qui pourraient aboutir à une erreur (ex: effacer le time de build_time). J'ai finalement fais un dernier test en ne modifiant qu'un seul paramètre, je copie le fichier dans le bon répertoire, je lance le jeu et Paf ! Rebelote !

 

Je sais que c'est ce fichier qui plante le jeu car j'ai testé tous les autres un par un pour m'assurer que tout fonctionne avec ces derniers

 

question : pourquoi ce fichier particulier embête ? Est-ce que je fais une erreur quelque part ? ou s'agît-il d'un bug ?

 

Pour info : j'ai fait une réinstallation totale et bien propre en respectant scrupuleusement les étapes successives

 

J'espère que quelqu'un pourra éclairer ma lanterne.

 

En attendant je voulais une fois de plus remercier l'équipe de développement pour tout le boulot que vous faites depuis tout ce temps. Rares sont à ma connaissance les mods qui continuent à évoluer 13 ans après la sortie du jeu ( mis à part Crossfire pour Freelancer) en tout cas chapeau ! 

 

 

 

P.S. (hors sujet) Darkgrazi j'ai visionné il y a quelques semaines la saison 2 de Discovery et j'ai bien aimé et finalement as-tu vu les dernières saisons d'Enterprise ?

Longue vie et prospérité à toi !

Edited by Spock72.ch

Share this post


Link to post
Share on other sites

Coucou, je reviens après une éternité pour test la dernière maj du mod. Malgré toutes les corrections de bug et crash, ils subsistent encore mais j'arrive à jouer sur une map de 80 planètes depuis plusieurs heures, ce qui n'était pas le cas avant, bravo.

 

Puis je me suis dit, après tant d'années à développer ce mod sur un moteur foireux, pourquoi ne pas avoir développé un jeu star wars copié de A à Z d'empire at war sur un moteur type unreal pour se passer des bugs et crash et offrant ainsi plus de possibilités?

Share this post


Link to post
Share on other sites

@ Madurk

A mon humble avis, développer un jeu de A à Z ce n'est pas la même chose que de modifier les programmes d'un jeu préexistant cette dernière option étant moins compliquée et demande moins d'effort (de connaissances ?) telle est mon opinion du moins. Après tout je ne suis à la place de nos cher moddeurs.

 

J'aimerai revenir au problème lié à la modification d'XML. Après plusieurs test et une nouvelle désinstallation/réinstallation dans les règles de l'art, j'ai constaté que dès que je remplace un fichier original par une version modifiée, je n'ai plus accès à certains bâtiments clés tels que centre de recrutement ou chantier naval Telgorn ne pouvant ainsi produire ni unités d'infanterie standard ni d'unités spatiales. j'ai testé aussi bien avec les rebelles qu'avec le consortium. C'est un peut comme si le jeu voulait me punir d'avoir modifié des fichiers XML.

 

a tout hasard j'utilises Wordpad pour ouvrir et modifier les XML et quand j'enregistre mon travail cela les transformes en .docx incompatibles avec mon office 2003 est-ce que tout ça peut jouer un rôle quelconque ?

 

 J'avoue y perdre mon latin (enfin pour ce que ça change, le latin et moi ça a toujours fait 2 :D:tongue:)

 

j'ai encore deux petites questions : il fut un temps (il y a longtemps) où vous proposiez un petit fichier XML qui réduisait les prix et temps de construction. Existe-t-il toujours ?

HK avait aussi conseillé de modifier le fichier gameconstants. Or j'ai ouvert l'ai ouvert mais je n'ai pas trouvé la ligne <Production_Speed_Factor>

cette solution est-elle toujours d'actualité ou ai-je un métro de retard ?

Edited by Spock72.ch

Share this post


Link to post
Share on other sites

utilise notepad++ pour modifier les xml , il permet de reperer plus rapidement les erreurs de codage (utf8 ou lua) .

 

ne pas installer le jeu dans programsfiles me parait essentiel , en fonction de la version de windows , de l'antivirus , le jeu peut etre ralenti , bloque surtout si les fichiers sont modifies .

 

 

Share this post


Link to post
Share on other sites

Merci Orvarth pour tes réponses. Je vais tout réinstaller hors de programesfiles

 

EDIT : J'ai tout réinstallé dans C: et j'ai modifié un fichier avec Notepad++ et ça fonctionne ! Merci pour tout !

Je n'ai plus qu'a m'atteler à la tâche de modification des fichiers

Edited by Spock72.ch

Share this post


Link to post
Share on other sites
Le 13/11/2019 à 22:25, Spock72.ch a dit :

 

P.S. (hors sujet) Darkgrazi j'ai visionné il y a quelques semaines la saison 2 de Discovery et j'ai bien aimé et finalement as-tu vu les dernières saisons d'Enterprise ?

Longue vie et prospérité à toi !

 

Salut ! Oui j'ai tous vu i;)

J'ai trouvé l'histoire de Discovery bien fait dans la ligné de Star Trek.

 

Longue vie et prospérité à toi aussi

Share this post


Link to post
Share on other sites
Le 14/11/2019 à 23:36, Spock72.ch a dit :

HK avait aussi conseillé de modifier le fichier gameconstants. Or j'ai ouvert l'ai ouvert mais je n'ai pas trouvé la ligne <Production_Speed_Factor> 

cette solution est-elle toujours d'actualité ou ai-je un métro de retard ?

Ligne 44.

Edited by HK 47

Share this post


Link to post
Share on other sites

@darkgrazi : Je trouve également que Discovery est bien faite, la saison 3 risque d'être fort intéressante, Quels défis vont attendre l'équipage du Discovery en ce 33ème siècle ?

 

Merci pour l'info HK !

Share this post


Link to post
Share on other sites

Bonjour à toutes et à tous !

Je viens d'installer SI sur la version GOG du jeu et j'aurais voulu savoir si je devais appliquer le patch 4gb ?

 

Merci par avance pour vos réponses

 

Edit :

Le chemin d'installation du mod pour la version GOG c'est : C:\Program Files (x86)\GOG Galaxy\Games\Star Wars - Empire At War Gold ou C:\Program Files (x86)\GOG Galaxy\Games\Star Wars - Empire At War Gold\EAWX ?

J'avoue être un peut perdu

 

Edit 2 :

C'est bon j'ai réinstallé SI dans C:\pro......\EAWX et ça fonctionne

Edited by Spock72.ch

Share this post


Link to post
Share on other sites
Il y a 17 heures, Spock72.ch a dit :

Bonjour à toutes et à tous !

Je viens d'installer SI sur la version GOG du jeu et j'aurais voulu savoir si je devais appliquer le patch 4gb ?

Je ne suis pas sûr mais dans le doute ça peut pas faire de mal.

Share this post


Link to post
Share on other sites

Bonjour à tous,

 

Je viens vers vous parce que je suis désespéré. Le mod SI ne fonctionne vrmt pas sur mon pc mais je ne comprends pas pk. Le jeu se lance et tout pas de soucis mais le jeu freezze complètement ou très longtemps dès qu'on dépasse les 5 mois.  (je teste sur la GC 3) 

J'ai deux versions du jeu une steam et une gog gold (#####é oui c est mal mais je voulais voir si c etait steam ou mon pc qui deconnait), les deux ont le meme genre de probleme de freezze (steam a des crash en plus mais probleme connu). Je précise enfin que je pense avoir lu TOUS les posts de ce forum par rapport au mod SI et je suis parfaitement conscient que ce bug est déja repertorié mais la c'est réellement injouable. 

Désolé pour le monologue qui va suivre mais j'aimerais comprendre ou est le problème donc je vais expliquer l'installation et mes tests.

Mon Pc

i5 7300HQ 2.5 gh 2.5 gh

8 go de ram

cg 1080gtx 

 

1) Version steam :

Apres installation du jeu sur la plateforme je suis la procédure en installant bien le mod dans le dossier corruption et je décompresse le patch 1.2n dans le même dossier. 

je lance le jeu via petrolauncher (mode comptabilité windows vista 3 et mode administrateur), j ai testé le patch 4gb sur le pétrolauncher mais je suis pas sur que cela marche comme ca. j'ai testé aussi le lanceur "playstrategicimprovment" mais meme resultat. 

Sur la version steam il s agit  d' un freeze intermittent qui commence au mois 6 et est de plus en plus conséquent a chaque mois passé. Je précise que j'ai réellement aucun problème avec les autres mods de steam donc ca vient soit du mod SI en lui meme soit d'une mauvaise manip ou autre de ma part. 

 

Version GOG

meme procédure que steam mais dans EAW

La il s'agit d un freeze définitif aléatoire a partir du mois 5 (mais ca ne prends jms plus d 'un demi mois pour qu'il refrezze après rechargement). 

 

 

J'adore votre travail mais je suis réellement frustré de ne plus pouvoir y jouer comme il y a quelques années donc si vous avez une idée pour me sortir du pétrin ?

Il faudrait peut etre que je prenne une ancienne version du mod ou l'ia est configurée différemment ?

Ou il y a une solution magique que j'ai pas vue ? 

 

Un grand merci d'avance pour vos réponses, 

 

 

 

 

Share this post


Link to post
Share on other sites

pour la version gog

 

le mode de compatibilite doit etre desactive , installer plutôt directx 9.0c (chez microsoft) c'est le meme effet en plus complet et en plus stable .

 

ne pas installer le jeu dans programsfiles (x86 ou autre) , une répertoire c:\games fera l'affaire a défaut d'un disque dedie pour les jeux .

 

pour la nvidia 1080 le dernier pilote 441.41 est plutot stable penser a mettre le pilote a niveau .

 

le patch 4g est a appliquer sur l'executable du jeu swfox.exe .

Share this post


Link to post
Share on other sites
Il y a 11 heures, orvarth a dit :

pour la version gog

 

le mode de compatibilite doit etre desactive , installer plutôt directx 9.0c (chez microsoft) c'est le meme effet en plus complet et en plus stable .

 

ne pas installer le jeu dans programsfiles (x86 ou autre) , une répertoire c:\games fera l'affaire a défaut d'un disque dedie pour les jeux .

 

pour la nvidia 1080 le dernier pilote 441.41 est plutot stable penser a mettre le pilote a niveau .

 

le patch 4g est a appliquer sur l'executable du jeu swfox.exe .

 

Pas de changement mais je ne comprends pas pourquoi il faut l appliquer mle patch  cet executable la alors que je ne peux lancer le mod que via petrolauncher 

Share this post


Link to post
Share on other sites

le petrolauncher est un raccourci incluant une configuration multiple pour pouvoir choisir different mods , rien de plus .

 

faite un raccourci sur le bureau  de   playstrategicimprovement.bat qui va ressembler a qq chose comme ca :

 

"D:\games\gog\Star Wars - Empire At War Gold\EAWX\PlayStrategicImprovement.bat"

 

le patch 4gb doit etre applique a l'executable , patcher un raccourci ne sert a rien , de meme il faut supprimer le mode de compatibilite sur swfoc.exe .

 

Ensuite les freezes peuvent survenir avec une mauvaise configuration du systeme , programmes preinstalles de machines hp ou autre marques de grandes distributions , ou alors la presence de plusieurs antivirus .

 

 

Edited by orvarth

Share this post


Link to post
Share on other sites
il y a 1 minute, orvarth a dit :

le petrolauncher est un raccourci incluant une configuration multiple pour pouvoir choidsir different mods , rien de plus .

 

faite un raccourci sur le bureau  de   playstrategicimprovement.bat qui va ressembler a qq chose comme ca :

 

"D:\games\gog\Star Wars - Empire At War Gold\EAWX\PlayStrategicImprovement.bat"

 

le patch 4gb doit etre applique a l'executable , patcher un raccourci ne sert a rien , de meme il faut supprimer le mode de compatibilite sur swfoc.exe .

 

Ensuite les freezes peuvent survenir avec une mauvaise configuration du systeme , programmes preinstalles de machines hp ou autre marques de grandes distributions , ou alors la presences de plusieurs antivirus .

 

 

J ai justement un hp et deux antivirus. Que puis je faire pour résoudre le probleme ? 

Share this post


Link to post
Share on other sites

sur win 10 il faut conserver celui de microsoft , c'est le plus performant actuellement aussi incroyable que cela puisse paraitre (sauf si le deuxieme est nod32) .

 

utiliser un outils de nettoyage : adwcleaner  

a cette adresse (attention au doppelgängers)   https://toolslib.net/downloads/viewdownload/1-adwcleaner/

 

globalement vous pouvez virer tous les progammes hp (sauf imprimante) et partenaires publicitaires sans problemes .

 

 

 

Share this post


Link to post
Share on other sites

J'ai avast gratuit et adwcleaner justement

Pour les applications HP je peux vrmt toutes les désinstaller ? J'ai 

HP 3D Driveguard

HP audio switch

HP coolsense

HP documentation

HP jumpstart

HP lounge

HP eprint

HP smart

HP support solutions framework

HP system event utility

Edited by pasteur007

Share this post


Link to post
Share on other sites
il y a 49 minutes, pasteur007 a dit :

J'ai avast gratuit et adwcleaner justement

Pour les applications HP je peux vrmt toutes les désinstaller ? J'ai 

HP 3D Driveguard

HP audio switch

HP coolsense

HP documentation

HP jumpstart

HP lounge

HP eprint

HP smart

HP support solutions framework

HP system event utility

vous pouvez supprimer avast (reactiver le defender de windows 10)  et tous les hp sans consequence pour le systeme , au contraire votre machine va respirer un peu .

Share this post


Link to post
Share on other sites

Bon sang de bois !

Je me trouve dans la même situation que Pasteur007 à une différence près : mon pc n'est pas un HP, mais un montage de pièces soigneusement choisies.

Version Gog : C:\Games\Gog\St.....\EAWX

swfoc.exe patché

Dx 9.0C (juin 2010) installé

aucune compatibilité sélectionnée

adwcleaner n'a trouvé aucuns fichiers à supprimer

Pour faire bonne mesure, j'ai passé CCleaner, mis à jour mon driver graphique et j'ai même redémarré mon pc après ça.

Résultat : Lag et freeze à répétition. Au 8ème mois du scénario Xénophobie impériale avec le consortium 10 sec de vitesse normale, freeze pendant 30 sec au moins et hop 10 sec normale, etc... Cela en devient injouable.

Suis-je maudit ou ais-je loupé une étape ?

Que faire ? J'ai envies de continuer à y jouer

 

W10

Intel i7 4790  4x 3.60 Ghz

Geoforce GTX 770

16 Go de RAM

Windows Defender n'a détecté aucun problème après un scan approfondi

 

Merci pour vos future réponses

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...